Portal Home > Knowledgebase > Articles Database > Question : NginxCP and CXS or PyxSoft Antimalware


Question : NginxCP and CXS or PyxSoft Antimalware




Posted by amos91, 11-11-2014, 09:29 AM
Hello , I am running a cPanel based dedicated web server , hosting only my personal websites I am using nginxcp as a reverse proxy to httpd i have installed PyxSoft antimalware plugin , apparently as it is stated on their website that this plugin does not work with either nginx or litehttpd , but i suspect they mean that the only web server that is running is either nginx or lighthttpd although when i log into the plugin panel it shows " HTTP Scanner Status: failed" is there is a way around this ? because i'd like to have pyxsoft antimalware to scan uploads to my server is it even possible to have an InspectFile directive in httpd while working in reverse proxy mode ? Thank you

Posted by amos91, 11-11-2014, 10:21 AM
Hello , Yes i have Is it possible to run modsecurity2 inspection with nginx configured as a reverse proxy ?

Posted by JohnCS, 11-20-2014, 06:50 AM
If nginx is configured as reverse proxy (as nginxcp.com do) you can easily run mod_security, CXS or any Apache addon. You just need to update Apache port to 8081 to your addon if the addon don't detect Apache port automatically.

Posted by Apolo, 11-21-2014, 03:38 PM
Moved to Hosting Security and Technology forum.

Posted by amos91, 11-21-2014, 03:42 PM
Hello , Thank you for moving the post to the right forum >> If nginx is configured as reverse proxy (as nginxcp.com do) you can easily run mod_security, CXS or any Apache addon The thing is , when i am running nginx as a reverse proxy neither CXS , Anti malware works properly , I do not think that this is a problem with modsecurity rather than scanning the files before they reside on the disk for some reason i do not fully understand , When i removed nginxcp from the host , both CXS and Pyxsoft worked just find . Anyone has a solution for this ? Thank you

Posted by aniga17, 11-22-2014, 01:45 PM
Please make sure you are passed all these: Software Requirements WHM/cPanel version 11.30 or superior Apache Web Server Mod Security 2.5 or superior installed ClamAV Antivirus installed Internal WHM Ioncube loader enabled Reference link Hope it helps Abdirizak



Was this answer helpful?

Add to Favourites Add to Favourites    Print this Article Print this Article

Also Read
crontab permissions? (Views: 593)
Swap in VPS (Views: 620)